re = /\G[^" \n]*(?:(?<!\\)"[^\n"]*(?<!\\)"[^" \n]*)*\K +/m
str = 'key1=value1 key1=value1 spaces="some spaces in text" nested1="key2=value2 key2=value2 key2=value2" nested2="key2=value2, key2=value2, key2=value2" quoted="his name is \\"no body\\""'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end