import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:^|\")[^\"\\n]*\"?)|,";
final String string = "1070,17,2,GN3-670,\"COLLAR B, M STAY\",\"2,606.45\"\n\n"
+ "foo, bar\n"
+ "foo, bar \"foo, bar, unclosed\n"
+ "foo, bar \"foo, bar\", baz, 1,2,3 \"4,5,6\"\n\n"
+ "a,b,c\n"
+ "\"a,b,c\" a,b,c \"\n"
+ "\"a,b,c\" a,b,c \"1,2,3\n"
+ "\"a,b,c\" a,b,c \"1,2,3\" \"unclosed,4,5";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}