$re = '/((?:^|")[^"\n]*"?)|,/m';
$str = '1070,17,2,GN3-670,"COLLAR B, M STAY","2,606.45"
foo, bar
foo, bar "foo, bar, unclosed
foo, bar "foo, bar", baz, 1,2,3 "4,5,6"
a,b,c
"a,b,c" a,b,c "
"a,b,c" a,b,c "1,2,3
"a,b,c" a,b,c "1,2,3" "unclosed,4,5';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;