import Foundation
let pattern = #"((?:^|")[^"\n]*"?)|,"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1070,17,2,GN3-670,"COLLAR B, M STAY","2,606.45"
foo, bar
foo, bar "foo, bar, unclosed
foo, bar "foo, bar", baz, 1,2,3 "4,5,6"
a,b,c
"a,b,c" a,b,c "
"a,b,c" a,b,c "1,2,3
"a,b,c" a,b,c "1,2,3" "unclosed,4,5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)