#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:(?<=Mr. )|(?<=Miss. )|(?<=Master. ))\w+|(?<=\()\w+)"
Local $sString = "Braund, Mr. Owen Harris" & @CRLF & _
"Cumings, Mrs. John Bradley (Florence Briggs Thayer)" & @CRLF & _
"Heikkinen, Miss. Laina" & @CRLF & _
"Futrelle, Mrs. Jacques Heath (Lily May Peel)" & @CRLF & _
"Allen, Mr. William Henry" & @CRLF & _
"Moran, Mr. James" & @CRLF & _
"McCarthy, Mr. Timothy J" & @CRLF & _
"Palsson, Master. Gosta Leonard" & @CRLF & _
"Johnson, Mrs. Oscar W (Elisabeth Vilhelmina Berg)" & @CRLF & _
"Nasser, Mrs. Nicholas (Adele Achem)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")