import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:(?<=Mr. )|(?<=Miss. )|(?<=Master. ))\\w+|(?<=\\()\\w+)";
final String string = "Braund, Mr. Owen Harris\n"
+ "Cumings, Mrs. John Bradley (Florence Briggs Thayer)\n"
+ "Heikkinen, Miss. Laina\n"
+ "Futrelle, Mrs. Jacques Heath (Lily May Peel)\n"
+ "Allen, Mr. William Henry\n"
+ "Moran, Mr. James\n"
+ "McCarthy, Mr. Timothy J\n"
+ "Palsson, Master. Gosta Leonard\n"
+ "Johnson, Mrs. Oscar W (Elisabeth Vilhelmina Berg)\n"
+ "Nasser, Mrs. Nicholas (Adele Achem)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}