# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:(?<=Mr. )|(?<=Miss. )|(?<=Master. ))\w+|(?<=\()\w+)"
test_str = ("Braund, Mr. Owen Harris\n"
"Cumings, Mrs. John Bradley (Florence Briggs Thayer)\n"
"Heikkinen, Miss. Laina\n"
"Futrelle, Mrs. Jacques Heath (Lily May Peel)\n"
"Allen, Mr. William Henry\n"
"Moran, Mr. James\n"
"McCarthy, Mr. Timothy J\n"
"Palsson, Master. Gosta Leonard\n"
"Johnson, Mrs. Oscar W (Elisabeth Vilhelmina Berg)\n"
"Nasser, Mrs. Nicholas (Adele Achem)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.