using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"border.*?#\s*(.*);\s*\/";
string substitution = @"12ff00";
string input = @"
border: 2px solid #a4002c; /**/
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}