re = /border.*?#\s*(.*);\s*\//m
str = '
border: 2px solid #a4002c; /**/
'
subst = '12ff00'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result