$re = '/border.*?#\s*(.*);\s*\//m';
$str = '
border: 2px solid #a4002c; /**/
';
$subst = "12ff00";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;