using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+:.*?(?=,?\s+\w+:|$)";
string input = @"dim1: 1, dim2: a, b, dim3: 3
dim1: 1, dim2: a, b dim3: 3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}