re = /\w+:.*?(?=,?\s+\w+:|$)/m
str = 'dim1: 1, dim2: a, b, dim3: 3
dim1: 1, dim2: a, b dim3: 3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end