$re = '/\w+:.*?(?=,?\s+\w+:|$)/m';
$str = 'dim1: 1, dim2: a, b, dim3: 3
dim1: 1, dim2: a, b dim3: 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);