#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^select][^\s].+[\(\)]?[^,|\s]"
Local $sString = "select count(rtnotes.keyno) as value," & @CRLF & _
" ent.company as label, " & @CRLF & _
" 'j-ChartDrillDown-406,'+CAST(ENT.ENTID AS CHAR(10)) AS link, " & @CRLF & _
" dateadd(week, datediff(wk, 0, dateadd(wk,-5,getdate())), -1) as test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")