re = /[^select][^\s].+[\(\)]?[^,|\s]/m
str = 'select count(rtnotes.keyno) as value,
ent.company as label,
\'j-ChartDrillDown-406,\'+CAST(ENT.ENTID AS CHAR(10)) AS link,
dateadd(week, datediff(wk, 0, dateadd(wk,-5,getdate())), -1) as test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end