package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^select][^\s].+[\(\)]?[^,|\s]`)
var str = `select count(rtnotes.keyno) as value,
ent.company as label,
'j-ChartDrillDown-406,'+CAST(ENT.ENTID AS CHAR(10)) AS link,
dateadd(week, datediff(wk, 0, dateadd(wk,-5,getdate())), -1) as test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}