package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<link [^>]+ href=\"(.+)\"`)
var str = `<link rel="stylesheet" type="text/css" href="style/style.css" />`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}