$re = '/<link [^>]+ href=\"(.+)\"/m';
$str = '<link rel="stylesheet" type="text/css" href="style/style.css" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);