re = /<link [^>]+ href=\"(.+)\"/m
str = '<link rel="stylesheet" type="text/css" href="style/style.css" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end