import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bfrom\\s+\\d{1,2}:\\d{2}\\K-(?=\\d{1,2}:\\d{2}(?!\\d))";
final String string = "he Spa center works from 08:00-20:30 every day";
final String subst = " to ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}