$re = '/\bfrom\s+\d{1,2}:\d{2}\K-(?=\d{1,2}:\d{2}(?!\d))/m';
$str = 'he Spa center works from 08:00-20:30 every day';
$subst = " to ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;