const regex = /\bfrom\s+\d{1,2}:\d{2}\K-(?=\d{1,2}:\d{2}(?!\d))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bfrom\\s+\\d{1,2}:\\d{2}\\K-(?=\\d{1,2}:\\d{2}(?!\\d))', 'gm')
const str = `he Spa center works from 08:00-20:30 every day`;
const subst = ` to `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);