#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\h*(?:(?:foo|bar)\h*)+$"
Local $sString = "foo bar ipsum dolor sit amet, consectetur adipiscing elit" & @CRLF & _
"" & @CRLF & _
"ipsum dolor sit amet, consectetur adipiscing elit foo" & @CRLF & _
"" & @CRLF & _
"ipsum dolor sit amet, bar consectetur adipiscing elit foo" & @CRLF & _
"" & @CRLF & _
"foo" & @CRLF & _
"" & @CRLF & _
"bar" & @CRLF & _
"" & @CRLF & _
"barfoo" & @CRLF & _
"" & @CRLF & _
"foobar" & @CRLF & _
"" & @CRLF & _
"foo bar" & @CRLF & _
"" & @CRLF & _
"foo bar foo bar foo bar foo bar" & @CRLF & _
"" & @CRLF & _
"foofoofoo" & @CRLF & _
"" & @CRLF & _
" foo bar" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")