import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\h*(?:(?:foo|bar)\\h*)+$";
final String string = "foo bar ipsum dolor sit amet, consectetur adipiscing elit\n\n"
+ "ipsum dolor sit amet, consectetur adipiscing elit foo\n\n"
+ "ipsum dolor sit amet, bar consectetur adipiscing elit foo\n\n"
+ "foo\n\n"
+ "bar\n\n"
+ "barfoo\n\n"
+ "foobar\n\n"
+ "foo bar\n\n"
+ "foo bar foo bar foo bar foo bar\n\n"
+ "foofoofoo\n\n"
+ " foo bar\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}