$re = '~^\h*(?:(?:foo|bar)\h*)+$~m';
$str = 'foo bar ipsum dolor sit amet, consectetur adipiscing elit
ipsum dolor sit amet, consectetur adipiscing elit foo
ipsum dolor sit amet, bar consectetur adipiscing elit foo
foo
bar
barfoo
foobar
foo bar
foo bar foo bar foo bar foo bar
foofoofoo
foo bar
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);