import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\|\\s*eval\\s+(?<field>\\w+)\\s*=\\s*(?<data>.*?)(?=\\s+\\|)";
final String string = "| eval var=case(\n"
+ " a,b,\n"
+ " c,d,\n"
+ " e,f)\n"
+ "| eval var2=case(\n"
+ " match(x, \"z|y|z\"), 1,\n"
+ " match(x, \"a|b|c\"), 2)\n"
+ "| eval var3=case(\n"
+ " match(x, \"z|y|z\"), 1,\n"
+ " match(x, \"a|b|c\"), 2) | eval var4=case(\n"
+ " match(x, \"z|y|z\"), 1,\n"
+ " match(x, \"a|b|c\"), 2)\n"
+ "|";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}