$re = '/(?s)\|\s*eval\s+(?<field>\w+)\s*=\s*(?<data>.*?)(?=\s+\|)/m';
$str = '| eval var=case(
a,b,
c,d,
e,f)
| eval var2=case(
match(x, "z|y|z"), 1,
match(x, "a|b|c"), 2)
| eval var3=case(
match(x, "z|y|z"), 1,
match(x, "a|b|c"), 2) | eval var4=case(
match(x, "z|y|z"), 1,
match(x, "a|b|c"), 2)
|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);