const regex = /(?s)\|\s*eval\s+(?<field>\w+)\s*=\s*(?<data>.*?)(?=\s+\|)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)\\|\\s*eval\\s+(?<field>\\w+)\\s*=\\s*(?<data>.*?)(?=\\s+\\|)', 'gm')
const str = `| eval var=case(
a,b,
c,d,
e,f)
| eval var2=case(
match(x, "z|y|z"), 1,
match(x, "a|b|c"), 2)
| eval var3=case(
match(x, "z|y|z"), 1,
match(x, "a|b|c"), 2) | eval var4=case(
match(x, "z|y|z"), 1,
match(x, "a|b|c"), 2)
|`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}