#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\[\^)([^\]\s\p{C}]+)(\])\ (\P{C}*(?:\n(?!\n[\[\n])\P{C}*)*)"
Local $sString = "Pseudo-example:" & @CRLF & _
"" & @CRLF & _
"Sentence of the first [^a]paragraph. Sentence[^b] of the first[^b] paragraph[^1]. Sentence of the first[^1] paragraph. Sentence[^1] of the first paragraph. Sentence of the first paragraph. Sentence of the first paragraph. Sentence of the first paragraph." & @CRLF & _
"" & @CRLF & _
"[^a] Sentence of a long margin note's body that refers to the word "paragraph"." & @CRLF & _
"" & @CRLF & _
"[^1] Sentence of the first paragraph of the footnote. Sentence of the first paragraph of the footnote. Sentence of the first paragraph of the footnote. Sentence of the first paragraph of the footnote." & @CRLF & _
"" & @CRLF & _
"Sentence of the second paragraph of the footnote. Sentence of the second paragraph of the footnote. Sentence of the second paragraph of the footnote. Sentence of the second paragraph of the footnote." & @CRLF & _
"" & @CRLF & _
"Sentence of the third and the last paragraph of the footnote and two empty lines after it!" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Sentence[^1] of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph." & @CRLF & _
"" & @CRLF & _
"[^b] Footnote at the end of the file. Footnote at the end of the file. Footnote at the end of the file."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")