const regex = /^(\[\^)([^\]\s\p{C}]+)(\])\ (\P{C}*(?:\n(?!\n[\[\n])\P{C}*)*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\[\\^)([^\\]\\s\\p{C}]+)(\\])\\ (\\P{C}*(?:\\n(?!\\n[\\[\\n])\\P{C}*)*)', 'gm')
const str = `Pseudo-example:
Sentence of the first [^a]paragraph. Sentence[^b] of the first[^b] paragraph[^1]. Sentence of the first[^1] paragraph. Sentence[^1] of the first paragraph. Sentence of the first paragraph. Sentence of the first paragraph. Sentence of the first paragraph.
[^a] Sentence of a long margin note's body that refers to the word "paragraph".
[^1] Sentence of the first paragraph of the footnote. Sentence of the first paragraph of the footnote. Sentence of the first paragraph of the footnote. Sentence of the first paragraph of the footnote.
Sentence of the second paragraph of the footnote. Sentence of the second paragraph of the footnote. Sentence of the second paragraph of the footnote. Sentence of the second paragraph of the footnote.
Sentence of the third and the last paragraph of the footnote and two empty lines after it!
Sentence[^1] of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph.
[^b] Footnote at the end of the file. Footnote at the end of the file. Footnote at the end of the file.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}