package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:crossing_success|series120_count)\[(\d+)]`)
var str = `x <- "
series120_count[1]; crossing_success[2]; tag_comments[small]
"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}