// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:crossing_success|series120_count)\[(\d+)]").unwrap();
let string = "x <- \"
series120_count[1]; crossing_success[2]; tag_comments[small]
\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}