import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[\\d!@#\\$%\\^&])(?=.*[a-z])(?=.*[A-Z]).{8,16}$";
final String string = "aA123456\n"
+ "aaaaaaA@\n"
+ "abcxyzD&\n"
+ "abababa$\n"
+ "abababa2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}