re = /^(?=.*[\d!@#\$%\^&])(?=.*[a-z])(?=.*[A-Z]).{8,16}$/m
str = 'aA123456
aaaaaaA@
abcxyzD&
abababa$
abababa2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end