$re = '/^(?=.*[\d!@#\$%\^&])(?=.*[a-z])(?=.*[A-Z]).{8,16}$/m';
$str = 'aA123456
aaaaaaA@
abcxyzD&
abababa$
abababa2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);