package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\S+) (\S+) (\S+) \[([\w:/]+\s[+\-]\d{4})\] (\S+) (\S+)\s*(\S+)?\s* (\d{3}) (\S+)`)
var str = `127.0.0.1 - - [01/Jul/1995:00:00:01 -0400] "GET /images/launch-logo.gif HTTP/1.0" 200 1839
127.0.0.1 - - [01/Jul/1995:00:00:01 -0400] "GET /" 200 1839
127.0.0.1 - - [01/Jul/1995:00:00:01 -0400] "GET / " 200 1839`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}