$re = '/^(\S+) (\S+) (\S+) \[([\w:/]+\s[+\-]\d{4})\] (\S+) (\S+)\s*(\S+)?\s* (\d{3}) (\S+)/m';
$str = '127.0.0.1 - - [01/Jul/1995:00:00:01 -0400] "GET /images/launch-logo.gif HTTP/1.0" 200 1839
127.0.0.1 - - [01/Jul/1995:00:00:01 -0400] "GET /" 200 1839
127.0.0.1 - - [01/Jul/1995:00:00:01 -0400] "GET / " 200 1839';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);