import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S+) (\\S+) (\\S+) \\[([\\w:/]+\\s[+\\-]\\d{4})\\] (\\S+) (\\S+)\\s*(\\S+)?\\s* (\\d{3}) (\\S+)";
final String string = "127.0.0.1 - - [01/Jul/1995:00:00:01 -0400] \"GET /images/launch-logo.gif HTTP/1.0\" 200 1839\n"
+ "127.0.0.1 - - [01/Jul/1995:00:00:01 -0400] \"GET /\" 200 1839\n\n"
+ "127.0.0.1 - - [01/Jul/1995:00:00:01 -0400] \"GET / \" 200 1839";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}