#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(flowers\.com)\/compare\._([^.]+)\.([^.]+)\.\d+(?:_([^.]+)\.([^.]+)\.\d+)?(?:_([^.]+)\.([^.]+)\.\d+)?(?:_([^.]+)\.([^.]+)\.\d+)?"
Local $sString = "https://flowers.com/compare._plant1.green.402992_plant2.yellow.402228_plant3.red.403010_plant4.orange.399987.html" & @CRLF & _
"" & @CRLF & _
"https://flowers.com/compare._plant1.green.402992_plant2.yellow.402228_plant3.red.403010.html" & @CRLF & _
"" & @CRLF & _
"https://flowers.com/compare._plant1.green.402992_plant2.yellow.402228.html" & @CRLF & _
"" & @CRLF & _
"https://flowers.com/compare._plant1.green.402992.html" & @CRLF & _
"" & @CRLF & _
"https://flowers.com/compare.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")