$re = '/(flowers\.com)\/compare\._([^.]+)\.([^.]+)\.\d+(?:_([^.]+)\.([^.]+)\.\d+)?(?:_([^.]+)\.([^.]+)\.\d+)?(?:_([^.]+)\.([^.]+)\.\d+)?/m';
$str = 'https://flowers.com/compare._plant1.green.402992_plant2.yellow.402228_plant3.red.403010_plant4.orange.399987.html
https://flowers.com/compare._plant1.green.402992_plant2.yellow.402228_plant3.red.403010.html
https://flowers.com/compare._plant1.green.402992_plant2.yellow.402228.html
https://flowers.com/compare._plant1.green.402992.html
https://flowers.com/compare.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);