const regex = new RegExp('(flowers\\.com)\\/compare\\._([^.]+)\\.([^.]+)\\.\\d+(?:_([^.]+)\\.([^.]+)\\.\\d+)?(?:_([^.]+)\\.([^.]+)\\.\\d+)?(?:_([^.]+)\\.([^.]+)\\.\\d+)?', 'gm')
const str = `https://flowers.com/compare._plant1.green.402992_plant2.yellow.402228_plant3.red.403010_plant4.orange.399987.html
https://flowers.com/compare._plant1.green.402992_plant2.yellow.402228_plant3.red.403010.html
https://flowers.com/compare._plant1.green.402992_plant2.yellow.402228.html
https://flowers.com/compare._plant1.green.402992.html
https://flowers.com/compare.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}