# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\s*\b(USA|UNITED STATES)\b/\1/gm;t' <<< "DETROIT
DETROIT USA
DETROIT UNITED STATES"