const regex = /.*\s*\b(USA|UNITED STATES)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\s*\\b(USA|UNITED STATES)\\b', 'gm')
const str = `DETROIT
DETROIT USA
DETROIT UNITED STATES`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);