$re = '/.*\s*\b(USA|UNITED STATES)\b/m';
$str = 'DETROIT
DETROIT USA
DETROIT UNITED STATES';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;