#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^<Version>(.*)<\/Version>$"
Local $sString = "<Project Sdk="Microsoft.NET.Sdk">" & @CRLF & _
" <PropertyGroup>" & @CRLF & _
" <TargetFramework>netstandard2.0</TargetFramework>" & @CRLF & _
" <NeutralLanguage>en-US</NeutralLanguage>" & @CRLF & _
" <Authors>Alex Volchetsky</Authors>" & @CRLF & _
" <Company />" & @CRLF & _
" <Product />" & @CRLF & _
" <Description>SDK for Yandex Alice skills development</Description>" & @CRLF & _
" <PackageProjectUrl>https://alexvolchetsky.github.io/yandex.alice.sdk</PackageProjectUrl>" & @CRLF & _
" <RepositoryUrl>https://github.com/alexvolchetsky/yandex.alice.sdk</RepositoryUrl>" & @CRLF & _
" <RepositoryType>git</RepositoryType>" & @CRLF & _
" <PackageTags>yandex alice skill dialogs models</PackageTags>" & @CRLF & _
" <PackageIcon>icon.png</PackageIcon>" & @CRLF & _
" <Version>1.0.4</Version>" & @CRLF & _
" <PackageLicenseFile>LICENSE.md</PackageLicenseFile>" & @CRLF & _
" <PackageReleaseNotes>Add intents integration</PackageReleaseNotes>" & @CRLF & _
" </PropertyGroup>" & @CRLF & _
"" & @CRLF & _
" <ItemGroup>" & @CRLF & _
" <PackageReference Include="Microsoft.CodeAnalysis.FxCopAnalyzers" Version="2.9.8">" & @CRLF & _
" <PrivateAssets>all</PrivateAssets>" & @CRLF & _
" <IncludeAssets>runtime; build; native; contentfiles; analyzers; buildtransitive</IncludeAssets>" & @CRLF & _
" </PackageReference>" & @CRLF & _
" <PackageReference Include="Microsoft.Extensions.Options" Version="3.1.5" />" & @CRLF & _
" <PackageReference Include="System.Text.Json" Version="4.7.1" />" & @CRLF & _
" </ItemGroup>" & @CRLF & _
"" & @CRLF & _
" <ItemGroup>" & @CRLF & _
" <Compile Update="Resources\Yandex.Alice.Sdk.Resources.Designer.cs">" & @CRLF & _
" <DesignTime>True</DesignTime>" & @CRLF & _
" <AutoGen>True</AutoGen>" & @CRLF & _
" <DependentUpon>Yandex.Alice.Sdk.Resources.resx</DependentUpon>" & @CRLF & _
" </Compile>" & @CRLF & _
" </ItemGroup>" & @CRLF & _
"" & @CRLF & _
" <ItemGroup>" & @CRLF & _
" <EmbeddedResource Update="Resources\Yandex.Alice.Sdk.Resources.resx">" & @CRLF & _
" <Generator>ResXFileCodeGenerator</Generator>" & @CRLF & _
" <LastGenOutput>Yandex.Alice.Sdk.Resources.Designer.cs</LastGenOutput>" & @CRLF & _
" </EmbeddedResource>" & @CRLF & _
" </ItemGroup>" & @CRLF & _
"" & @CRLF & _
" <ItemGroup>" & @CRLF & _
" <None Include="..\..\LICENSE.md">" & @CRLF & _
" <Pack>True</Pack>" & @CRLF & _
" <PackagePath></PackagePath>" & @CRLF & _
" </None>" & @CRLF & _
" <None Include="Resources\icon.png">" & @CRLF & _
" <Pack>True</Pack>" & @CRLF & _
" <PackagePath></PackagePath>" & @CRLF & _
" </None>" & @CRLF & _
" </ItemGroup>" & @CRLF & _
"" & @CRLF & _
"</Project>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")