// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^<Version>(.*)<\/Version>$").unwrap();
let string = "<Project Sdk=\"Microsoft.NET.Sdk\">
<PropertyGroup>
<TargetFramework>netstandard2.0</TargetFramework>
<NeutralLanguage>en-US</NeutralLanguage>
<Authors>Alex Volchetsky</Authors>
<Company />
<Product />
<Description>SDK for Yandex Alice skills development</Description>
<PackageProjectUrl>https://alexvolchetsky.github.io/yandex.alice.sdk</PackageProjectUrl>
<RepositoryUrl>https://github.com/alexvolchetsky/yandex.alice.sdk</RepositoryUrl>
<RepositoryType>git</RepositoryType>
<PackageTags>yandex alice skill dialogs models</PackageTags>
<PackageIcon>icon.png</PackageIcon>
<Version>1.0.4</Version>
<PackageLicenseFile>LICENSE.md</PackageLicenseFile>
<PackageReleaseNotes>Add intents integration</PackageReleaseNotes>
</PropertyGroup>
<ItemGroup>
<PackageReference Include=\"Microsoft.CodeAnalysis.FxCopAnalyzers\" Version=\"2.9.8\">
<PrivateAssets>all</PrivateAssets>
<IncludeAssets>runtime; build; native; contentfiles; analyzers; buildtransitive</IncludeAssets>
</PackageReference>
<PackageReference Include=\"Microsoft.Extensions.Options\" Version=\"3.1.5\" />
<PackageReference Include=\"System.Text.Json\" Version=\"4.7.1\" />
</ItemGroup>
<ItemGroup>
<Compile Update=\"Resources\\Yandex.Alice.Sdk.Resources.Designer.cs\">
<DesignTime>True</DesignTime>
<AutoGen>True</AutoGen>
<DependentUpon>Yandex.Alice.Sdk.Resources.resx</DependentUpon>
</Compile>
</ItemGroup>
<ItemGroup>
<EmbeddedResource Update=\"Resources\\Yandex.Alice.Sdk.Resources.resx\">
<Generator>ResXFileCodeGenerator</Generator>
<LastGenOutput>Yandex.Alice.Sdk.Resources.Designer.cs</LastGenOutput>
</EmbeddedResource>
</ItemGroup>
<ItemGroup>
<None Include=\"..\\..\\LICENSE.md\">
<Pack>True</Pack>
<PackagePath></PackagePath>
</None>
<None Include=\"Resources\\icon.png\">
<Pack>True</Pack>
<PackagePath></PackagePath>
</None>
</ItemGroup>
</Project>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}