import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^<Version>(.*)<\\/Version>$";
final String string = "<Project Sdk=\"Microsoft.NET.Sdk\">\n"
+ " <PropertyGroup>\n"
+ " <TargetFramework>netstandard2.0</TargetFramework>\n"
+ " <NeutralLanguage>en-US</NeutralLanguage>\n"
+ " <Authors>Alex Volchetsky</Authors>\n"
+ " <Company />\n"
+ " <Product />\n"
+ " <Description>SDK for Yandex Alice skills development</Description>\n"
+ " <PackageProjectUrl>https://alexvolchetsky.github.io/yandex.alice.sdk</PackageProjectUrl>\n"
+ " <RepositoryUrl>https://github.com/alexvolchetsky/yandex.alice.sdk</RepositoryUrl>\n"
+ " <RepositoryType>git</RepositoryType>\n"
+ " <PackageTags>yandex alice skill dialogs models</PackageTags>\n"
+ " <PackageIcon>icon.png</PackageIcon>\n"
+ " <Version>1.0.4</Version>\n"
+ " <PackageLicenseFile>LICENSE.md</PackageLicenseFile>\n"
+ " <PackageReleaseNotes>Add intents integration</PackageReleaseNotes>\n"
+ " </PropertyGroup>\n\n"
+ " <ItemGroup>\n"
+ " <PackageReference Include=\"Microsoft.CodeAnalysis.FxCopAnalyzers\" Version=\"2.9.8\">\n"
+ " <PrivateAssets>all</PrivateAssets>\n"
+ " <IncludeAssets>runtime; build; native; contentfiles; analyzers; buildtransitive</IncludeAssets>\n"
+ " </PackageReference>\n"
+ " <PackageReference Include=\"Microsoft.Extensions.Options\" Version=\"3.1.5\" />\n"
+ " <PackageReference Include=\"System.Text.Json\" Version=\"4.7.1\" />\n"
+ " </ItemGroup>\n\n"
+ " <ItemGroup>\n"
+ " <Compile Update=\"Resources\\Yandex.Alice.Sdk.Resources.Designer.cs\">\n"
+ " <DesignTime>True</DesignTime>\n"
+ " <AutoGen>True</AutoGen>\n"
+ " <DependentUpon>Yandex.Alice.Sdk.Resources.resx</DependentUpon>\n"
+ " </Compile>\n"
+ " </ItemGroup>\n\n"
+ " <ItemGroup>\n"
+ " <EmbeddedResource Update=\"Resources\\Yandex.Alice.Sdk.Resources.resx\">\n"
+ " <Generator>ResXFileCodeGenerator</Generator>\n"
+ " <LastGenOutput>Yandex.Alice.Sdk.Resources.Designer.cs</LastGenOutput>\n"
+ " </EmbeddedResource>\n"
+ " </ItemGroup>\n\n"
+ " <ItemGroup>\n"
+ " <None Include=\"..\\..\\LICENSE.md\">\n"
+ " <Pack>True</Pack>\n"
+ " <PackagePath></PackagePath>\n"
+ " </None>\n"
+ " <None Include=\"Resources\\icon.png\">\n"
+ " <Pack>True</Pack>\n"
+ " <PackagePath></PackagePath>\n"
+ " </None>\n"
+ " </ItemGroup>\n\n"
+ "</Project>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}