package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{{image:[^}]*?}}`)
var str = `var str = 'This is just a sample text followed by an {{image: imageUrl1}}. And here is another {{image: imageUrl2}}.';
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}