re = /{{image:[^}]*?}}/
str = 'var str = \'This is just a sample text followed by an {{image: imageUrl1}}. And here is another {{image: imageUrl2}}.\';
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end