$re = '/{{image:[^}]*?}}/';
$str = 'var str = \'This is just a sample text followed by an {{image: imageUrl1}}. And here is another {{image: imageUrl2}}.\';
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);